리스토리의 IT's/Security

OpenSSL 취약점 보안 업데이트 권고(CVE-2022-0778)

리스토리 2022. 3. 18. 12:29
반응형
Openssl
□ 개요
o OpenSSL에서 발생하는 취약점을 해결한 보안 업데이트 발표
o 낮은 버전 사용자는 서비스 거부 공격에 취약하므로, 최신 버전으로 업데이트 권고

□ 설명 [1]
o OpenSSL 내 BN_mod_sqrt() 함수에서 연산 시 무한 루프로 인해 발생하는 서비스 거부 취약점(CVE-2022-0778)

□ 영향 받는 버전
o OpenSSL 1.0.2 및 이전 버전
o OpenSSL 1.1.1 및 이전 버전
o OpenSSL 3.0 및 이전 버전

□ 해결 방안
o 해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이트[2]
- OpenSSL 1.0.2 버전 사용자 : 1.0.2zd 버전으로 업데이트
- OpenSSL 1.1.1 버전 사용자 : 1.1.1n 버전으로 업데이트
- OpenSSL 3.0 버전 사용자 : 3.0.2 버전로 업데이트
※ OpenSSL 1.0.2 버전(Premium Level Support 사용자 제외) 및 1.1.0 버전은 더 이상 업데이트가 지원되지 않으니 OpenSSL 1.1.1n 또는 3.0.2 버전으로 변경할 것을 권고

[참고사이트]
[1] https://www.openssl.org/news/secadv/20220315.txt
[2] https://www.openssl.org/source/
반응형