2022/03 9

Spring Java 프레임워크 보안 업데이트 권고

□ 개요 o Spring 보안팀에서 Spring 프레임워크 및 Spring Cloud Function 관련 원격코드 실행 취약점을 해결한 임시조치 방안 및 보안업데이트 권고 o 공격자는 해당 취약점을 이용하여 정상 서비스에 피해를 발생시킬 수 있으므로, 최신 버전으로 업데이트 권고 □ 주요 내용 o Spring Core에서 발생하는 원격코드실행 취약점(Spring4Shell 취약점)[1] o Spring Cloud Function에서 발생하는 원격코드실행 취약점 (CVE-2022-22963)[2] □ 영향을 받는 버전 o Spring4Shell - 1) JDK 9 이상의 2) Spring 프레임워크 사용하는 경우 ※ JDK 8 이하의 경우 취약점의 영향을 받지 않음 o CVE-2022-22963 - Sp..

구글 Chrome 브라우저 보안 업데이트 권고(CVE-2022-1096)

□ 개요 o 구글社는 자사 제품에서 발생하는 취약점을 해결한 보안 업데이트 발표 [1] o 공격자는 해당 취약점을 악용하여 피해를 발생시킬 수 있으므로, 해당 제품을 사용하는 이용자들은 최신 버전으로 업데이트 권고 □ 설명 o 크롬 브라우저의 V8엔진에서 발생하는 Type Confusion 취약점(CVE-2022-1096) □ 영향을 받는 버전 및 해결 버전 제품명 : Chrome 영향 받는 버전 : 99.0.4844.84 이전 버전 해결 버전 : 99.0.4844.84 ※ 하단의 참고 사이트를 확인하여 업데이트 확인 및 수행 [2] [참고사이트] [1] https://chromereleases.googleblog.com/2022/03/stable-channel-update-for-desktop_25.h..

OpenSSL 취약점 보안 업데이트 권고(CVE-2022-0778)

□ 개요 o OpenSSL에서 발생하는 취약점을 해결한 보안 업데이트 발표 o 낮은 버전 사용자는 서비스 거부 공격에 취약하므로, 최신 버전으로 업데이트 권고 □ 설명 [1] o OpenSSL 내 BN_mod_sqrt() 함수에서 연산 시 무한 루프로 인해 발생하는 서비스 거부 취약점(CVE-2022-0778) □ 영향 받는 버전 o OpenSSL 1.0.2 및 이전 버전 o OpenSSL 1.1.1 및 이전 버전 o OpenSSL 3.0 및 이전 버전 □ 해결 방안 o 해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이트[2] - OpenSSL 1.0.2 버전 사용자 : 1.0.2zd 버전으로 업데이트 - OpenSSL 1.1.1 버전 사용자 : 1.1.1n 버전으로 업데이트 - OpenSS..

구글 Chrome 브라우저 보안 업데이트 권고(99.0.4844.74)

□ 개요 o 구글社는 자사 제품에서 발생하는 취약점을 해결한 보안 업데이트 발표 [1] o 공격자는 해당 취약점을 악용하여 피해를 발생시킬 수 있으므로, 해당 제품을 사용하는 이용자들은 최신 버전으로 업데이트 권고 □ 설명 o 크롬 브라우저의 ANGLE에서 발생하는 Use-after-free 취약점 (CVE-2022-0975) 등 10개 □ 영향을 받는 버전 및 해결 버전 제품명 : Chrome 영향 받는 버전 : 99.0.4844.74 이전 버전 해결 버전 : 99.0.4844.74 ※ 하단의 참고 사이트를 확인하여 업데이트 확인 및 수행 [2] [참고사이트] [1] https://chromereleases.googleblog.com/2022/03/stable-channel-update-for-desk..

리눅스 커널 로컬 권한 상승 취약점(dirty pipe) 보안 업데이트 권고(CVE-2022-0847)

□ 개요 o 리눅스 재단은 자사의 커널에서 발생하는 보안 취약점에 대한 보안 업데이트 발표 o 공격자는 취약점을 악용하여 피해를 발생시킬 수 있으므로, 영향받는 제품을 이용 중인 사용자는 최신버전으로 보안 업데이트 권고 □ 설명 o pipe에서 권한 검증이 미흡하여 발생하는 로컬 권한 상승 취약점(CVE-2022-0847) □ 영향 받는 버전 o Linux Kernel 5.8를 포함한 이후 버전을 사용하는 시스템 □ 해결 버전 o Linux Kernel 5.16.11, 5.15.25, 5.10.102 버전 □ 해결 방안 o 해당 취약점에 해당되는 커널 버전 사용자는 최신 버전으로 업데이트 수행 o 보안 업데이트가 공개된 운영체제를 운영하고 있을 경우, 참고 사이트의 내용을 참조하여 보안 조치 또는 업데이..

[보안 공지] 구글 Chrome 브라우저 보안 업데이트 권고(99.0.4844.51 이전 버전)

□ 개요 o 구글社는 자사 제품에서 발생하는 취약점을 해결한 보안 업데이트 발표 [1] o 공격자는 해당 취약점을 악용하여 피해를 발생시킬 수 있으므로, 해당 제품을 사용하는 이용자들은 최신 버전으로 업데이트 권고 □ 설명 o 크롬 브라우저의 Cast UI에서 발생하는 Use-after-free 취약점 등 8건(CVE-2022-0790, CVE-2022-0791, CVE-2022-0793 등 8건) o 크롬 브라우저의 ANGLE에서 발생하는 힙 오버플로 취약점 등 13건(CVE-2022-0789, CVE-2022-0800, CVE-2022-0801 등 13건) □ 영향을 받는 버전 및 해결 버전 제품명 : Chrome 영향 받는 버전 : 99.0.4844.51 이전 버전 해결 버전 : 99.0.4844...